# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:-|(?P<real_ip>[\-\da-f.:, ]+)) - (?<remote_user>\S+) \[(?<timestamp>[^\]]+)\]\s+\"(?:\-|(?<request>\w+) (?<request_uri>[^ \?]+)(?:\?(?<request_uri_query>[^ ]*))? (?<request_version>[\w\/\.]+))\"\s+(?P<status>[1-9]\d{2})\s+(?P<body_bytes_sent>\d+)\s+\"(?<http_referer>[^\"]+)\"\s+\"(?<http_user_agent>[^\"]+)\"\s+\"(?P<remote_ip>[\da-f.:]+)\" (?:\-|(?P<upstream_response_time>\d+(?:.\d+)?))\s+(?P<request_time>\d+(?:.\d+)?) (?P<pipe>[\.p])"
test_str = ("10.100.7.118 - - [02/Aug/2022:19:27:57 +0800] \"GET /api/article/list/news HTTP/1.1\" 200 103594 \"https://165.npa.gov.tw/\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36\" \"172.27.31.231\" 0.062 0.062 .\n\n"
"49.216.25.168, 203.66.34.45 - - [02/Aug/2022:19:28:10 +0800] \"GET /assets/i18n/zh-tw.json HTTP/1.1\" 200 9760 \"https://165.npa.gov.tw/\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 15_6 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148\" \"172.27.31.231\" 0.031 0.031 .\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.