import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:-|(?P<real_ip>[\\-\\da-f.:, ]+)) - (?<remote_user>\\S+) \\[(?<timestamp>[^\\]]+)\\]\\s+\"(?:\\-|(?<request>\\w+) (?<request_uri>[^ \\?]+)(?:\\?(?<request_uri_query>[^ ]*))? (?<request_version>[\\w\\/\\.]+))\"\\s+(?P<status>[1-9]\\d{2})\\s+(?P<body_bytes_sent>\\d+)\\s+\"(?<http_referer>[^\"]+)\"\\s+\"(?<http_user_agent>[^\"]+)\"\\s+\"(?P<remote_ip>[\\da-f.:]+)\" (?:\\-|(?P<upstream_response_time>\\d+(?:.\\d+)?))\\s+(?P<request_time>\\d+(?:.\\d+)?) (?P<pipe>[\\.p])";
final String string = "10.100.7.118 - - [02/Aug/2022:19:27:57 +0800] \"GET /api/article/list/news HTTP/1.1\" 200 103594 \"https://165.npa.gov.tw/\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36\" \"172.27.31.231\" 0.062 0.062 .\n\n"
+ "49.216.25.168, 203.66.34.45 - - [02/Aug/2022:19:28:10 +0800] \"GET /assets/i18n/zh-tw.json HTTP/1.1\" 200 9760 \"https://165.npa.gov.tw/\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 15_6 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148\" \"172.27.31.231\" 0.031 0.031 .\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}