// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/)?(www\.)?(\S+)(\.[^\s\/]+)(\/\S*)?").unwrap();
let string = "https://www.google.com
http://coreyms.com
https://www.youtube.com/watch?v=sa-TUpSx1JA
https://www.nasa.gov
www.desmos.com
pastebin.com/s8fh3HAs
https://www.regex101.com/
www.translate.google.com/
https://roblox.com/home
chat.openai.com/?model=text-davinci-002-render-sha
https://www.amazon.com/
agar.io/#ffa";
let substitution = "$3$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}