$re = '/(https?:\/\/)?(www\.)?(\S+)(\.[^\s\/]+)(\/\S*)?/m';
$str = 'https://www.google.com
http://coreyms.com
https://www.youtube.com/watch?v=sa-TUpSx1JA
https://www.nasa.gov
www.desmos.com
pastebin.com/s8fh3HAs
https://www.regex101.com/
www.translate.google.com/
https://roblox.com/home
chat.openai.com/?model=text-davinci-002-render-sha
https://www.amazon.com/
agar.io/#ffa';
$subst = "$3$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;