$re = '/\d{1,9}(eur.*)? honoraires? exclus/m';
$str = '----------------------------------------------------------------------------------
[REGEX_1 = hors honoraires?:? (:\\s)?\\d{1,9}]
----------------------------------------------------------------------------------
prix hors honoraires 900 000 €. no
prix hors honoraire 900 000 €. no
prix hors honoraire: 900 000 €. no
prix hors honoraires 168 000 € ttc.
prix hors honoraires 600 000 € ht.
prix hors honoraires 125 000 €. no
prix hors honoraires 2 500 000 € pa
prix hors honoraires 100 000 €. no
prix hors honoraires 250 000 € h
prix hors honoraires: 250 000 € h
prix de vente hors honoraires : 620 000 €
----------------------------------------------------------------------------------
[REGEX_2 = \\d{1,9} ([a-zA-Z_\\/€²]{1,12}) hors honoraires?]
----------------------------------------------------------------------------------
1 050 000 € hors honoraires
450 000 euros hors honoraires
287600 eur hors honoraires
450 ht/hc/m²/an hors honoraires
450 € /m2 ht/hc/an hors honoraires
450 m²/an/ ht hc et hors honoraires
----------------------------------------------------------------------------------
[REGEX_3 = \\d{1,9}(eur.*)? hors honoraires?]
----------------------------------------------------------------------------------
65 000 hors honoraires
400000eur hors honoraires
----------------------------------------------------------------------------------
[REGEX_4 = honoraires? exclus:? (:\\s)?\\d{1,9}]
----------------------------------------------------------------------------------
prix honoraires exclus : 80 000 eur
prix honoraires exclus : 550 000 eur
prix honoraires exclus: 550 000 eur
----------------------------------------------------------------------------------
[REGEX_5 = \\d{1,9} ([a-zA-Z_\\/€²]{1,12}) honoraires? exclus]
----------------------------------------------------------------------------------
65 000 eur honoraires exclus
400000 ht/hc/m²/an honoraires exclus
----------------------------------------------------------------------------------
[REGEX_6 = \\d{1,9}(eur.*)? honoraires? exclus]
----------------------------------------------------------------------------------
65 000 honoraires exclus
400000eur ht/hc/m²/an honoraires exclus
400000eur honoraires exclus
[GOOD ONE]
prix honoraires exclus
honoraires exclus
prix hors honoraires
bail 30/06/22 hors honoraires
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);