#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,9}(eur.*)? honoraires? exclus"
Local $sString = "----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_1 = hors honoraires?:? (:\s)?\d{1,9}]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"prix hors honoraires 900 000 €. no" & @CRLF & _
"prix hors honoraire 900 000 €. no" & @CRLF & _
"prix hors honoraire: 900 000 €. no" & @CRLF & _
"prix hors honoraires 168 000 € ttc." & @CRLF & _
"prix hors honoraires 600 000 € ht. " & @CRLF & _
"prix hors honoraires 125 000 €. no" & @CRLF & _
"prix hors honoraires 2 500 000 € pa" & @CRLF & _
"prix hors honoraires 100 000 €. no" & @CRLF & _
"prix hors honoraires 250 000 € h" & @CRLF & _
"prix hors honoraires: 250 000 € h" & @CRLF & _
"prix de vente hors honoraires : 620 000 €" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_2 = \d{1,9} ([a-zA-Z_\/€²]{1,12}) hors honoraires?]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"1 050 000 € hors honoraires" & @CRLF & _
"450 000 euros hors honoraires" & @CRLF & _
"287600 eur hors honoraires" & @CRLF & _
"450 ht/hc/m²/an hors honoraires" & @CRLF & _
"450 € /m2 ht/hc/an hors honoraires" & @CRLF & _
"450 m²/an/ ht hc et hors honoraires" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_3 = \d{1,9}(eur.*)? hors honoraires?]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"65 000 hors honoraires " & @CRLF & _
"400000eur hors honoraires " & @CRLF & _
"" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_4 = honoraires? exclus:? (:\s)?\d{1,9}]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"prix honoraires exclus : 80 000 eur" & @CRLF & _
"prix honoraires exclus : 550 000 eur" & @CRLF & _
"prix honoraires exclus: 550 000 eur" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_5 = \d{1,9} ([a-zA-Z_\/€²]{1,12}) honoraires? exclus]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"65 000 eur honoraires exclus" & @CRLF & _
"400000 ht/hc/m²/an honoraires exclus" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"[REGEX_6 = \d{1,9}(eur.*)? honoraires? exclus]" & @CRLF & _
"----------------------------------------------------------------------------------" & @CRLF & _
"65 000 honoraires exclus" & @CRLF & _
"400000eur ht/hc/m²/an honoraires exclus" & @CRLF & _
"400000eur honoraires exclus" & @CRLF & _
"" & @CRLF & _
"[GOOD ONE]" & @CRLF & _
"prix honoraires exclus " & @CRLF & _
"honoraires exclus " & @CRLF & _
"prix hors honoraires " & @CRLF & _
"bail 30/06/22 hors honoraires" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")