$re = '/[^\s|,|(|)]+/';
$str = '( 61.1, -6.5, -764.96, 4 )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);