package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\s|,|(|)]+`)
var str = `( 61.1, -6.5, -764.96, 4 )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}