const regex = /([^-]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^-]*)$', 'gm')
const str = `12345-LATIS
234134-CRISE
13241234-P-ORACLE
134134-ORACLE
1341324-ENS
134134-P-NIBS
134123415-LATIS
11513423-CRISE
1-34555
A-33433
12-23434
5-3451-A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}