#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^-]*)$"
Local $sString = "12345-LATIS" & @CRLF & _
"234134-CRISE" & @CRLF & _
"13241234-P-ORACLE" & @CRLF & _
"134134-ORACLE" & @CRLF & _
"1341324-ENS" & @CRLF & _
"134134-P-NIBS" & @CRLF & _
"134123415-LATIS" & @CRLF & _
"11513423-CRISE" & @CRLF & _
"1-34555" & @CRLF & _
"A-33433" & @CRLF & _
"12-23434" & @CRLF & _
"5-3451-A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")