re = /[^abc]+[أبجدهـوزحطيكلمنسعفصقرشتثخذضظؤاإءئةى]+/m
str = 'كلمات عربية يقبل حرفين او اكثر'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end