package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^abc]+[أبجدهـوزحطيكلمنسعفصقرشتثخذضظؤاإءئةى]+`)
var str = `كلمات عربية يقبل حرفين او اكثر`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}