import Foundation
let pattern = #"(?<=\"id\"\:)\d+(?=\,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"id": 5987431,
"remoteRef": "f150edeab22e5458a8d5db64280023f0",
"paymentEntityType": "Bank",
"accountHolder": "Svilen Varbanov",
"accountNumber": "********6691",
"expiresEnd": null,
"paymentEntityStatus": "Unverified",
"token": null,
"canDeposit": false,
"canWithdraw": false,
"lastUsed": false,
"cardType": null,
"logs": [
{
"paymentEntityStatus": "Unverified",
"message": "Bank payment entity has been created.",
"updated": "2019-10-01 11:49:22Z"
}
],
"transactionSummaries": null,
"paymentGateway": "RBC",
"details": {
"bankName": null,
"sortCode": null,
"swiftCode": null,
"branchCode": null,
"branchAddress": null,
"transitNumber": "340",
"institutionNumber": "34103",
"accountId": "575876691"
},
"createdAt": "2019-10-01T11:49:22.4680708Z"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)