using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\""id\""\:)\d+(?=\,)";
string input = @"{
""id"": 5987431,
""remoteRef"": ""f150edeab22e5458a8d5db64280023f0"",
""paymentEntityType"": ""Bank"",
""accountHolder"": ""Svilen Varbanov"",
""accountNumber"": ""********6691"",
""expiresEnd"": null,
""paymentEntityStatus"": ""Unverified"",
""token"": null,
""canDeposit"": false,
""canWithdraw"": false,
""lastUsed"": false,
""cardType"": null,
""logs"": [
{
""paymentEntityStatus"": ""Unverified"",
""message"": ""Bank payment entity has been created."",
""updated"": ""2019-10-01 11:49:22Z""
}
],
""transactionSummaries"": null,
""paymentGateway"": ""RBC"",
""details"": {
""bankName"": null,
""sortCode"": null,
""swiftCode"": null,
""branchCode"": null,
""branchAddress"": null,
""transitNumber"": ""340"",
""institutionNumber"": ""34103"",
""accountId"": ""575876691""
},
""createdAt"": ""2019-10-01T11:49:22.4680708Z""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}