$re = '/(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}/m';
$str = 'BE15-7878-0144-5741
BE15001470142457
BE1235-16152-216510-152615620
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);