#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}"
Local $sString = "BE15-7878-0144-5741 " & @CRLF & _
"BE15001470142457" & @CRLF & _
"BE1235-16152-216510-152615620" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")