$re = '/^(\d{10}|\d{12})$/m';
$str = '1234567890
123456789012
123456789
12345678901234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);