package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{10}|\d{12})$`)
var str = `1234567890
123456789012
123456789
12345678901234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}