# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?smi)^\|[^\n]+\|\n?\n"
test_str = ("|Runtime version|Shipped with |Internal version|\n"
"|---------------|-----------------------------------|----------------| \n"
"|`1.0` |Business Central April 2018 Release|12.0|\n"
"|`2.0` |Business Central Fall '18 Release |13.0|\n"
"|`3.0` |Business Central Spring '19 Release|14.0|\n"
"|`4.0` |Business Central 2019 release wave 2|15.0|\n"
"|`5.0` |Business Central 2020 release wave 1|16.0|\n"
"|`6.0` |Business Central 2020 release wave 2|17.0|\n"
"|`6.1` |Business Central 2020 release wave 2 update 1|17.1|\n"
"|`6.2` |Business Central 2020 release wave 2 update 2|17.2|\n"
"|`6.3` |Business Central 2020 release wave 2 update 3|17.3|\n"
"|`6.4` |Business Central 2020 release wave 2 update 4|17.4|\n"
"|`7.0` |Business Central 2021 release wave 1|18.0|\n"
"|`7.1` |Business Central 2021 release wave 1 update 1|18.1|\n"
"|`7.2` |Business Central 2021 release wave 1 update 2|18.2|\n"
"|`8.0` |Business Central 2021 release wave 2|19.0|\n"
"|`9.0` |Business Central 2022 release wave 1|20.0|\n"
"|`9.1` |Business Central 2022 release wave 1 update 1|20.1|\n"
"|`9.2` |Business Central 2022 release wave 1 update 2|20.2|\n"
"|`10.0` |Business Central 2022 release wave 2|21.0|\n"
"|`11.0` |Business Central 2023 release wave 1|22.0|\n"
"|`12.0` |Business Central 2023 release wave 2|23.0|\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.