const regex = /(?smi)^\|[^\n]+\|\n?\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?smi)^\\|[^\\n]+\\|\\n?\\n', 'gm')
const str = `|Runtime version|Shipped with |Internal version|
|---------------|-----------------------------------|----------------|
|\`1.0\` |Business Central April 2018 Release|12.0|
|\`2.0\` |Business Central Fall '18 Release |13.0|
|\`3.0\` |Business Central Spring '19 Release|14.0|
|\`4.0\` |Business Central 2019 release wave 2|15.0|
|\`5.0\` |Business Central 2020 release wave 1|16.0|
|\`6.0\` |Business Central 2020 release wave 2|17.0|
|\`6.1\` |Business Central 2020 release wave 2 update 1|17.1|
|\`6.2\` |Business Central 2020 release wave 2 update 2|17.2|
|\`6.3\` |Business Central 2020 release wave 2 update 3|17.3|
|\`6.4\` |Business Central 2020 release wave 2 update 4|17.4|
|\`7.0\` |Business Central 2021 release wave 1|18.0|
|\`7.1\` |Business Central 2021 release wave 1 update 1|18.1|
|\`7.2\` |Business Central 2021 release wave 1 update 2|18.2|
|\`8.0\` |Business Central 2021 release wave 2|19.0|
|\`9.0\` |Business Central 2022 release wave 1|20.0|
|\`9.1\` |Business Central 2022 release wave 1 update 1|20.1|
|\`9.2\` |Business Central 2022 release wave 1 update 2|20.2|
|\`10.0\` |Business Central 2022 release wave 2|21.0|
|\`11.0\` |Business Central 2023 release wave 1|22.0|
|\`12.0\` |Business Central 2023 release wave 2|23.0|
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}