const regex = /^\+(\d{3}|\d{2}|\d{1})\s\((\d{3}|\d{2}|\d{1})\)\s(\d{3}|\d{2}|\d{1})\-(\d{2}|\d{1})\-(\d{2}|\d{1})/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+(\\d{3}|\\d{2}|\\d{1})\\s\\((\\d{3}|\\d{2}|\\d{1})\\)\\s(\\d{3}|\\d{2}|\\d{1})\\-(\\d{2}|\\d{1})\\-(\\d{2}|\\d{1})', 'm')
const str = `+189 (377) 123-12-34
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}