package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+(\d{3}|\d{2}|\d{1})\s\((\d{3}|\d{2}|\d{1})\)\s(\d{3}|\d{2}|\d{1})\-(\d{2}|\d{1})\-(\d{2}|\d{1})`)
var str = `+189 (377) 123-12-34
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}