$re = '/(\w*)([()=,]*)(\w*)/';
$str = 'avg(x, y, z, a, b, c)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);