package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)([()=,]*)(\w*)`)
var str = `avg(x, y, z, a, b, c)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}