const regex = /https?:\/\/(?:www\.)?lazada\.co\.id\/([\w.'_-]+(\/([\w-]+))?).html/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:www\\.)?lazada\\.co\\.id\\\/([\\w.\'_-]+(\\\/([\\w-]+))?).html', '')
const str = `https://shp.ee/auu7tfs.sa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}