package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(?:www\.)?lazada\.co\.id\/([\w.'_-]+(\/([\w-]+))?).html`)
var str = `https://shp.ee/auu7tfs.sa`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}