# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"!::(?<FinancialProcessor>\d+)\~(?<FormatVersion>\d+)\~(?<TransactionGroupId>\d+)\~(?<SharedSnowFlake>SHRD\w+)\~(?<Acct1PurposeTypeId>\d)(?<Acct1SignType>\W)(?<Acct1PublicId>\w{32})\~(?<Acct2>(?<Acct2PurposeTypeId>\d)(?<Acct2SignType>\W)(?<Acct2PublicId>\w{32}))?\~(?<Acct3>(?<Acct3PurposeTypeId>\d)(?<Acct3SignType>\W)(?<Acct3PublicId>\w{32}))?\~(?<CardTransactionTypeId>\d+)?\~(?<TransactionAccountingId>.{1,50})?\~(?<FeeScheduleId>\d+)?::!"
test_str = ("!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~~1002::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~~::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~~~::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~~~~::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~~::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~~1002::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~BlahBlah Blabh~1002::!\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~10~BlahBlah Blabh~1002::!\n"
"In the !::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::! middle of a string\n"
"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::! - Transferred From Shiny Black Box Account")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.