using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!::(?<FinancialProcessor>\d+)\~(?<FormatVersion>\d+)\~(?<TransactionGroupId>\d+)\~(?<SharedSnowFlake>SHRD\w+)\~(?<Acct1PurposeTypeId>\d)(?<Acct1SignType>\W)(?<Acct1PublicId>\w{32})\~(?<Acct2>(?<Acct2PurposeTypeId>\d)(?<Acct2SignType>\W)(?<Acct2PublicId>\w{32}))?\~(?<Acct3>(?<Acct3PurposeTypeId>\d)(?<Acct3SignType>\W)(?<Acct3PublicId>\w{32}))?\~(?<CardTransactionTypeId>\d+)?\~(?<TransactionAccountingId>.{1,50})?\~(?<FeeScheduleId>\d+)?::!";
string input = @"!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~~1002::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~~::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~~~::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~~~~::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~~::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~~1002::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~~BlahBlah Blabh~1002::!
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~~~10~BlahBlah Blabh~1002::!
In the !::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::! middle of a string
!::1~1~293328075~SHRD05G5E4B7SA8I0~0-23e744f20f034caab6d5e4ca8a0e5e24~0+1ca4529ec1d74243b87da4fbb89e5455~0$b316bb02ed4e4246a1f269d135cd27c7~10~BlahBlah Blabh~1002::! - Transferred From Shiny Black Box Account";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}