re = /^[^\r\n]*(?<=\\)("|\\)[^\r\n]*$/m
str = 'abc d
my \\"laser\\"
D:\\\\willi\\\\badehose
foo\\\\\\"bar
my "laser"
D:\\willi\\badehose
foo\\\\"bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end