$re = '/^[^\r\n]*(?<=\\\\)("|\\\\)[^\r\n]*$/m';
$str = 'abc d
my \\"laser\\"
D:\\\\willi\\\\badehose
foo\\\\\\"bar
my "laser"
D:\\willi\\badehose
foo\\\\"bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);