re = /(\b((?!(at))\w)+\b)/m
str = 'Match words not containing at.
Cathy\'s black cat is fast.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end