$re = '/(\b((?!(at))\w)+\b)/m';
$str = 'Match words not containing at.
Cathy\'s black cat is fast.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);