const regex = /(?<book>\S+)\s*(?<chapters>(?<from>[0-9]+)(\s*-\s*(?<to>[0-9]+))*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<book>\\S+)\\s*(?<chapters>(?<from>[0-9]+)(\\s*-\\s*(?<to>[0-9]+))*)', 'gm')
const str = `Matthieu 2 - 14
Jean 2-10
Apocalypse 12-22
Genèse 1- 10
Nombres 1- 10
Luc 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}