package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<book>\S+)\s*(?<chapters>(?<from>[0-9]+)(\s*-\s*(?<to>[0-9]+))*)`)
var str = `Matthieu 2 - 14
Jean 2-10
Apocalypse 12-22
Genèse 1- 10
Nombres 1- 10
Luc 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}