use strict;
my $str = 'SIN UB X/RGN101.29ESGR UB NYT110.00YOW UB RGN110.00YOW RGN UB SIN 101';
my $regex = qr/^(((([A-Z]+-)?((\d{2})([A-Z]{3})(\d{2}))?([A-Z]{3})?( )?((.[0-9A-Z]{3})|([0-9A-Z]{2}))( )([X][\/])?((E\/)|(B\/)|(T\/)|(L\/))*(([A-Z][\/-])?[A-Z]{3})?(?!\d{1,3}[A-Z\s])( )?(((E\/XXX)?|([Q]{1}(( )?([A-Z]{3})([A-Z]{3}))?(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(M( )?([A-Z]{6})?( )?(\d{1,6}(\.\d{1,4})?)?)?|([R]{1}(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(([0-9])*S(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(M?\/(IT))|(M?\/(BT))|(\/\/([A-Z]{3})))( )?)*(\d+M( )?)?((?![0-9][A-Z])\d{1,6}(\.\d{1,4})?( )?)?((?<=[0-9])((?![A-Z][A-Z0-9]( )([A-Z]\/)?[A-Z]{3}|NUC|END|[A-Z]{3}( )[0-9])|(?=[A-Z][A-Z0-9]( )NUC))[A-Z][A-Z0-9\/]{0,8})?(( )?(([Q]{1}(\d+M)?(\d{1,6}(\.\d{1,4})?))|(P R\/([A-Z]{3})(\/)?([A-Z]{3})?( )?(\d+M)?(\d{1,6}(\.\d{1,4})?))|(P( )([A-Z]{6})( )?([A-Z]{6})?( )?(\d+M)?(\d{1,6}(\.\d{1,4})?))|(M( )?([A-Z]{6})?( )?(\d{1,6}(\.\d{1,4})?)?)|(H( )([A-Z]{6})( )?(\d{1,6}(\.\d{1,4})?))|(U( )(( )?([A-Z]{6}))+( )?(\d{1,6}(\.\d{1,4})?))|(C\/([A-Z]{3})(( )?[A-Z]{6})*( )?(\d{1,6}(\.\d{1,4})?))|(D( )((([A-Z])+\/)?([A-Z]{6})( )?((M)|(\d+M)|( )|(\d{1,6}(\.\d{1,4})?))( )?)+)|(\/-([A-Z]{3}))|(\/\/([A-Z]{3})))?( )?)*)+)+)( )?((( )?([A-Z]{3})( )?(\d{1,6}(\.\d{1,4})?))( )?(END)|(END))( )?(ROE( )?\d+(\.\d+)?)?(.*)?$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}