const regex = /^(((([A-Z]+-)?((\d{2})([A-Z]{3})(\d{2}))?([A-Z]{3})?( )?((.[0-9A-Z]{3})|([0-9A-Z]{2}))( )([X][\/])?((E\/)|(B\/)|(T\/)|(L\/))*(([A-Z][\/-])?[A-Z]{3})?(?!\d{1,3}[A-Z\s])( )?(((E\/XXX)?|([Q]{1}(( )?([A-Z]{3})([A-Z]{3}))?(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(M( )?([A-Z]{6})?( )?(\d{1,6}(\.\d{1,4})?)?)?|([R]{1}(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(([0-9])*S(\d+M)?(\d{1,6}(\.\d{1,4})?))?|(M?\/(IT))|(M?\/(BT))|(\/\/([A-Z]{3})))( )?)*(\d+M( )?)?((?![0-9][A-Z])\d{1,6}(\.\d{1,4})?( )?)?((?<=[0-9])((?![A-Z][A-Z0-9]( )([A-Z]\/)?[A-Z]{3}|NUC|END|[A-Z]{3}( )[0-9])|(?=[A-Z][A-Z0-9]( )NUC))[A-Z][A-Z0-9\/]{0,8})?(( )?(([Q]{1}(\d+M)?(\d{1,6}(\.\d{1,4})?))|(P R\/([A-Z]{3})(\/)?([A-Z]{3})?( )?(\d+M)?(\d{1,6}(\.\d{1,4})?))|(P( )([A-Z]{6})( )?([A-Z]{6})?( )?(\d+M)?(\d{1,6}(\.\d{1,4})?))|(M( )?([A-Z]{6})?( )?(\d{1,6}(\.\d{1,4})?)?)|(H( )([A-Z]{6})( )?(\d{1,6}(\.\d{1,4})?))|(U( )(( )?([A-Z]{6}))+( )?(\d{1,6}(\.\d{1,4})?))|(C\/([A-Z]{3})(( )?[A-Z]{6})*( )?(\d{1,6}(\.\d{1,4})?))|(D( )((([A-Z])+\/)?([A-Z]{6})( )?((M)|(\d+M)|( )|(\d{1,6}(\.\d{1,4})?))( )?)+)|(\/-([A-Z]{3}))|(\/\/([A-Z]{3})))?( )?)*)+)+)( )?((( )?([A-Z]{3})( )?(\d{1,6}(\.\d{1,4})?))( )?(END)|(END))( )?(ROE( )?\d+(\.\d+)?)?(.*)?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((([A-Z]+-)?((\\d{2})([A-Z]{3})(\\d{2}))?([A-Z]{3})?( )?((.[0-9A-Z]{3})|([0-9A-Z]{2}))( )([X][\\\/])?((E\\\/)|(B\\\/)|(T\\\/)|(L\\\/))*(([A-Z][\\\/-])?[A-Z]{3})?(?!\\d{1,3}[A-Z\\s])( )?(((E\\\/XXX)?|([Q]{1}(( )?([A-Z]{3})([A-Z]{3}))?(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))?|(M( )?([A-Z]{6})?( )?(\\d{1,6}(\\.\\d{1,4})?)?)?|([R]{1}(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))?|(([0-9])*S(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))?|(M?\\\/(IT))|(M?\\\/(BT))|(\\\/\\\/([A-Z]{3})))( )?)*(\\d+M( )?)?((?![0-9][A-Z])\\d{1,6}(\\.\\d{1,4})?( )?)?((?<=[0-9])((?![A-Z][A-Z0-9]( )([A-Z]\\\/)?[A-Z]{3}|NUC|END|[A-Z]{3}( )[0-9])|(?=[A-Z][A-Z0-9]( )NUC))[A-Z][A-Z0-9\\\/]{0,8})?(( )?(([Q]{1}(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))|(P R\\\/([A-Z]{3})(\\\/)?([A-Z]{3})?( )?(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))|(P( )([A-Z]{6})( )?([A-Z]{6})?( )?(\\d+M)?(\\d{1,6}(\\.\\d{1,4})?))|(M( )?([A-Z]{6})?( )?(\\d{1,6}(\\.\\d{1,4})?)?)|(H( )([A-Z]{6})( )?(\\d{1,6}(\\.\\d{1,4})?))|(U( )(( )?([A-Z]{6}))+( )?(\\d{1,6}(\\.\\d{1,4})?))|(C\\\/([A-Z]{3})(( )?[A-Z]{6})*( )?(\\d{1,6}(\\.\\d{1,4})?))|(D( )((([A-Z])+\\\/)?([A-Z]{6})( )?((M)|(\\d+M)|( )|(\\d{1,6}(\\.\\d{1,4})?))( )?)+)|(\\\/-([A-Z]{3}))|(\\\/\\\/([A-Z]{3})))?( )?)*)+)+)( )?((( )?([A-Z]{3})( )?(\\d{1,6}(\\.\\d{1,4})?))( )?(END)|(END))( )?(ROE( )?\\d+(\\.\\d+)?)?(.*)?$', 'g')
const str = `SIN UB X/RGN101.29ESGR UB NYT110.00YOW UB RGN110.00YOW RGN UB SIN 101`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}