re = /(@|#)[0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12}/m
str = 'dsd#439a31eb-ee62-4769-9e10-93e08ed3709cds+dasd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end