using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(@|#)[0-9A-Fa-f]{8}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{4}[-][0-9A-Fa-f]{12}";
string input = @"dsd#439a31eb-ee62-4769-9e10-93e08ed3709cds+dasd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}