$re = '/_[000]{3}_/m';
$str = 'I215_QM_20180523435433222_000_2343200023432.xml
I215_QM_20180523435433222_232_
I215_QM_20180523435433222_432_
I215_QM_20180523435433222_333_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);