using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_[000]{3}_";
string input = @"I215_QM_20180523435433222_000_2343200023432.xml
I215_QM_20180523435433222_232_
I215_QM_20180523435433222_432_
I215_QM_20180523435433222_333_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}