re = /(<p>(?=<img\s.*?))(.*?)(<\/p>)/m
str = '<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p><p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
'
subst = '<figure class="image">\\2</figure>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result