# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<p>(?=<img\s.*?))(.*?)(</p>)"
test_str = ("<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n"
"<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n\n"
"<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n\n"
"<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p><p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n")
subst = "<figure class=\"image\">\\2</figure>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.