const regex = new RegExp('((?:[a-z0-9\\.\\-\\+]*):\\/\\/(?:[^\\s:@\\/]+(?::[^\\s:@\\/]*)?@)?(?:(?:25[0-5]|2[0-4]\\d|[0-1]?\\d?\\d)(?:\\.(?:25[0-5]|2[0-4]\\d|[0-1]?\\d?\\d)){3}|\\[[0-9a-f:\\.]+\\]|([a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*\\.(?!-)(?:[a-z_-_-]{2,63}|xn--[a-z0-9]{1,59})(?<!-)\\.?|[a-z_-_0-9](?:[a-z_-_0-9-]{0,61}[a-z_-_0-9])?(?:\\.(?!-)[a-z_-_0-9-]{1,63}(?<!-))*|localhost))(?::\\d{2,5})?(?:[\\/?#][^\\s]*)?\\Z)', 'gm')
const str = `http://www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}