$re = '/.{24}10(?P<lot>\w{2,20})/m';
$str = '010340093595583817211231105577211234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);