using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{24}10(?P<lot>\w{2,20})";
string input = @"010340093595583817211231105577211234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}