use strict;
my $str = 'S-Buy BL460c G6 E5540 8G 2P Svr
BL460c G6 X5550 6G 1P Svr
BL460c G6 E5540 6G 1P Svr
BL460c G6 E5540 6G 1P Svr
BL460c G6 E5530 6G 1P Svr
BL460c G6 L5520 6G 1P Svr
BL460c G6 E5520 6G 1P Svr
BL460c G6 E5506 6G 1P Svr
BL460c G6 E5502 6G 1P Svr
BL280c G6 L5520 2G LP 1P Svr
BL280c G6 E5520 2G 1P Svr
BL280c G6 E5540 2G 1P Svr
BL280c G6 E5502 2G 1P Svr
S-Buy BL460c G6 E5540 8G 2P Svr
S-Buy BL460c G6 E5530 4G 1P Svr
S-Buy BL460c G6 E5530 4G 1P Svr
BL2x220c G6 E5540 24G 2P 250GB Svr
BL2x220c G6 E5530 24G 2P 250GB Svr
BL2x220c G6 L5530 24G 2P 250GB Svr
BL2x220c G6 L5520 24G 2P
BL2x220c G6 E5640 2x2P 24G Svr
BL2x220c G6 E5630 2x2P 24G Svr
BL2x220c G6 L5640 2x2P 24G Svr
BL2x220c G6 Mod0 Svr
BL280c G6 X5650 6G 1P Svr
BL280c G6 E5630 4G 1P Svr
BL280c G6 L5640 4G 1P Svr
BL280c G6 E5506 2G 1P Svr
BL620c G7 E7-2860 32G Svr
BL620c G7 E7-2850 32G Svr
BL620c G7 E7-2830 32G Svr
BL680c G7 E7-4860 64G Svr
BL680c G7 E7-4860 64G Svr
BL680c G7 E7-4850 64G Svr
BL680c G7 E7-4830 64G Svr
';
my $regex = qr/\b(?!\d)([ELX0-9-])\w{1,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}