import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\d)([ELX0-9-])\\w{1,}";
final String string = "S-Buy BL460c G6 E5540 8G 2P Svr\n"
+ "BL460c G6 X5550 6G 1P Svr\n"
+ "BL460c G6 E5540 6G 1P Svr\n"
+ "BL460c G6 E5540 6G 1P Svr\n"
+ "BL460c G6 E5530 6G 1P Svr\n"
+ "BL460c G6 L5520 6G 1P Svr\n"
+ "BL460c G6 E5520 6G 1P Svr\n"
+ "BL460c G6 E5506 6G 1P Svr\n"
+ "BL460c G6 E5502 6G 1P Svr\n"
+ "BL280c G6 L5520 2G LP 1P Svr\n"
+ "BL280c G6 E5520 2G 1P Svr\n"
+ "BL280c G6 E5540 2G 1P Svr\n"
+ "BL280c G6 E5502 2G 1P Svr\n"
+ "S-Buy BL460c G6 E5540 8G 2P Svr\n"
+ "S-Buy BL460c G6 E5530 4G 1P Svr\n"
+ "S-Buy BL460c G6 E5530 4G 1P Svr\n"
+ "BL2x220c G6 E5540 24G 2P 250GB Svr\n"
+ "BL2x220c G6 E5530 24G 2P 250GB Svr\n"
+ "BL2x220c G6 L5530 24G 2P 250GB Svr\n"
+ "BL2x220c G6 L5520 24G 2P\n"
+ "BL2x220c G6 E5640 2x2P 24G Svr\n"
+ "BL2x220c G6 E5630 2x2P 24G Svr\n"
+ "BL2x220c G6 L5640 2x2P 24G Svr\n"
+ "BL2x220c G6 Mod0 Svr\n"
+ "BL280c G6 X5650 6G 1P Svr\n"
+ "BL280c G6 E5630 4G 1P Svr\n"
+ "BL280c G6 L5640 4G 1P Svr\n"
+ "BL280c G6 E5506 2G 1P Svr\n"
+ "BL620c G7 E7-2860 32G Svr\n"
+ "BL620c G7 E7-2850 32G Svr\n"
+ "BL620c G7 E7-2830 32G Svr\n"
+ "BL680c G7 E7-4860 64G Svr\n"
+ "BL680c G7 E7-4860 64G Svr\n"
+ "BL680c G7 E7-4850 64G Svr\n"
+ "BL680c G7 E7-4830 64G Svr\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}