re = /[0-9]{4}-[0-9]{2}-[0-9]{2}_[0-9]{2}-[0-9]{2}-[0-9]{2}-[0-9]{6}/m
str = 'condor_2022-10-17_17-22-36-978729'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end