package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{4}-[0-9]{2}-[0-9]{2}_[0-9]{2}-[0-9]{2}-[0-9]{2}-[0-9]{6}`)
var str = `condor_2022-10-17_17-22-36-978729`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}