re = /spring-.*-\d\.\d.xsd/
str = 'spring-beans-2.3.xsd
spring-beans-3.0.xsd
spring-beans.xsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end